Sauce Labs Maintenance Windows for Sauce Labs
Customers may experience intermittent errors during automated browser and virtual mobile device tests in our US-West-1 datacenter. We are closely monitoring and investigating the affected services.
2023-May-17 Resolved Service Incident
Incident Report for Sauce Labs
Postmortem

Dates:

Wednesday May 17th 2023, 18:44 - 19:30 UTC

What happened:

During a secondary router upgrade in our EU-Central datacenter, network traffic was dropped in our virtual Mac Cloud.

Why it happened:

There was a misconfiguration within the network of our Mac Cloud virtualization vendor that was uncovered during the secondary router upgrade. 

How we fixed it:

Traffic was routed back to the primary router. Once traffic reverted to using the primary Mac Cloud link, service was restored.

What we are doing to prevent it from happening again:

During a recent maintenance window, we worked with the vendor to address the misconfiguration and tested the failover process. The router upgrade will be scheduled for the next EU Maintenance window.

Posted Jun 02, 2023 - 18:14 UTC

Resolved
Between 18:45 UTC and 19:30 UTC, we experienced Mac and iOS mobile test failures in EU-Central-1 Data Center. The issue is now resolved. All services are fully operational.
Posted May 17, 2023 - 19:52 UTC