Sauce Labs Maintenance Windows for Sauce Labs
Sauce Labs will have a four hour previously scheduled maintenance window on Wednesday, July 10th, starting at 04:00 UTC and ending at 08:00 UTC. During this maintenance window, we will be making updates to our infrastructure and services in our US West data center. These maintenance actions may cause portions of the service (including running automated and manual tests) to be unavailable for up to four hours.
2024-September-9 Service Incident
Incident Report for Sauce Labs
Postmortem

Dates:

Friday September 6 2024, 20:30 UTC - Monday September 9 2024, 11:57 UTC

What happened:

RDC devices in the US-West had intermittent connectivity issues.

Why it happened:

An unexpected, intermittent DNS resolution failure began occurring after a new DNS 

server was added.

How we fixed it:

The  faulty DNS server was removed.

What we are doing to prevent it from happening again:

Additional monitoring for this particular network failure was added.

Posted Sep 23, 2024 - 10:12 UTC

Resolved
After taking remedial action all services are operating as normal. This incident is resolved.
Posted Sep 09, 2024 - 13:29 UTC
Update
We are currently seeing intermittent network connectivity issues in Live and Automated Real Device tests in the US-West-1 Data Center. We are still investigating.
Posted Sep 09, 2024 - 12:42 UTC
Investigating
We are currently seeing intermittent network connectivity issues in iOS Live and Automated Real Device tests in the US-West-1 Data Center. We are investigating.
Posted Sep 09, 2024 - 10:58 UTC
This incident affected: Automated Real Device Testing (US-West), Live Real Device Testing (US-West), and Native Framework Mobile App Testing (US-West).