Sauce Labs Maintenance Windows for Sauce Labs
We are aware of and working to resolve intermittent WiFi connectivity and slowness issues affecting Android Real Devices in our US-West-1 data center. During a maintenance window on September 25, we made changes to our wireless infrastructure which has greatly improved the situation, but we are still monitoring and working on further improvements. Please contact our Support team should you wish to report any such issues.

2021-Dec-15 Minor Service Incident
Incident Report for Sauce Labs
Postmortem

Dates:

Wednesday December 15th 2021, 12:20 - 15:20 UTC

What happened:

The /rest/v1/info/status REST API endpoint started returning an error message instead of the normal “all OK“ message.

Why it happened:

A change was deployed that changed the underlying settings used by the affected REST API endpoint.

How we fixed it:

The change was reversed.

What we are doing to prevent it from happening again:

We will be adding additional monitoring and alerting and post deploy tests for this REST API endpoint.

Posted Dec 22, 2021 - 15:08 UTC

Resolved
This issue is resolved and the affected endpoint is operating correctly.
Posted Dec 15, 2021 - 15:22 UTC
Investigating
The REST API “/rest/v1/info/status” is returning data to indicate a service issue, this is a false positive but we are investigating. At this time all Sauce Labs services are operating as expected.
Posted Dec 15, 2021 - 13:54 UTC
This incident affected: Sauce Labs REST API (US-West, EU-Central).