Sauce Labs Maintenance Window
We are experiencing intermittent issues with iOS Simulators and MacOS desktop browser tests in our US-West data center, caused by a third-party service disruption. Our engineering team is actively coordinating with the provider to restore full service.

2026-July-01 Service Incident

Incident Report for Sauce Labs

Resolved

We have identified the root cause and have deployed a fix for this issue. All services are fully operational.
Posted Jul 01, 2026 - 12:58 UTC

Investigating

We are experiencing an issue with accessing Appium Inspector in the US-West-1, EU-Central-1, and US-East-4 data centers. We are investigating.
Posted Jul 01, 2026 - 12:12 UTC