Sauce Labs Maintenance Windows for Sauce Labs
Sauce Labs will have a four hour previously scheduled maintenance window on Wednesday, July 10th, starting at 04:00 UTC and ending at 08:00 UTC. During this maintenance window, we will be making updates to our infrastructure and services in our US West data center. These maintenance actions may cause portions of the service (including running automated and manual tests) to be unavailable for up to four hours.
2023-November-19 Service Incident
Incident Report for Sauce Labs
Postmortem

Dates:

Thursday November 16th 2023, 16:11 - Sunday 19 November 06:20 UTC

What happened:

A subset of customers and prospects intermittently experienced 403 responses and/or partial page loads for the Sauce Labs marketing website.

Why it happened:

While rolling out new network security features, a specific rule was set to a sensitivity level that resulted in false positives triggering in some conditions.

How we fixed it:

The sensitivity level of the offending rule was decreased.

What we are doing to prevent it from happening again:

We have improved the dashboard for all rules, introduced alerts for rule thresholds being exceeded, and improved our ability to quickly filter through logs to identify false positives.

Posted Jan 10, 2024 - 08:45 UTC

Resolved
After taking remedial action, saucelabs.com is now loading successfully. All services are fully operational.
Posted Nov 19, 2023 - 06:47 UTC
Identified
We have identified the root cause and a fix is being implemented.
Posted Nov 19, 2023 - 06:04 UTC
Investigating
Some users may receive a 403 response or notice broken images on saucelabs.com. The Sauce Labs application is unaffected. We are investigating.
Posted Nov 19, 2023 - 05:34 UTC
This incident affected: Other (saucelabs.com).