Sauce Labs Maintenance Windows for Sauce Labs
Sauce Labs has consolidated onto one status page for all data centers.

The old status pages for US-West, US-East and EU-Central are still available to be able to view incident history. Anyone who was subscribed to notifications from one of the old status pages has been migrated onto this consolidated page. If you received an email saying that you had been unsubscribed from notifications, that was from one of the old pages and can be disregarded.

If you would like to select which components that you receive notifications for (e.g. if you are only interested in receiving notifications about incidents affecting Real Device Testing), you can access the subscription management page by clicking "Subscribe To Updates" above and enter the email address you are subscribed with. Additionally there is a "Manage Your Subscription" link on any email you will receive from the status page going forward.
2021-February-11 Resolved Service Incident
Incident Report for Sauce Labs
Postmortem

Dates:

February 11 05:45 - February 11 07:00 PST

What happened:

The Application Storage service in Sauce Labs EU-Central-1 Data Center was experiencing issues resulting in intermittent HTTP status code 500 errors when uploading files and starting tests using applications in storage.

Why it happened:

An unexpected API change was introduced in one of the third-party components that the Application Storage service is interacting with to store and retrieve its data.

How we fixed it:

Our Application Storage client code was been patched to update the way we work with this third-party service.

What we are doing to prevent it from happening again:

We are monitoring API changes in related third-party components, so that we are able to react in advance of changes having an impact on our service.

Posted Feb 22, 2021 - 09:12 UTC

Resolved
Between 13:40 and 14:50 EST, uploading apps in Live Testing intermittently failed with error 500. In addition, starting Automated and Live a tests with mobile apps in Sauce Application Storage intermittently failed with application installation errors. This affected the EU-Central data center only.
Posted Feb 11, 2021 - 14:00 UTC