Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 23, 2023 - 17:00 UTC
Scheduled
Sauce Labs will have a two hour previously scheduled maintenance window on September 23rd, starting at 17:00 UTC and ending at 19:00 UTC. During this maintenance window, we will be making updates to our infrastructure and services in our EU-Central data center. These maintenance actions may cause portions of the service (including running automated and manual tests) to be unavailable for up to two hours.
Posted Jun 01, 2023 - 21:38 UTC
This scheduled maintenance affected: Automated Virtual Mobile Device Testing (EU-Central), Automated Real Device Testing (EU-Central), Live Browser Testing (EU-Central), Live Virtual Mobile Device Testing (EU-Central), Live Real Device Testing (EU-Central), Insights (EU-Central), Billing (EU-Central), IPSec VPN (EU-Central), Native Framework Mobile App Testing (EU-Central), API Testing (EU-Central), Automated Browser Testing (EU-Central), Sauce Connect (EU-Central), Sauce Labs REST API (EU-Central), and Sauce Labs Dashboard (EU-Central).