Sauce Labs Maintenance Windows for Sauce Labs
Customers may experience intermittent errors during automated browser and virtual mobile device tests in our US-West-1 datacenter. We are closely monitoring and investigating the affected services.
2022-June-10 Resolved Service Incident
Incident Report for Sauce Labs
Postmortem

Dates:

June 10th 2022, 17.19 - 17:26 UTC

What happened:

Visual testing builds were not working as expected. Customers were either experiencing builds not finishing or builds being queued for active sessions.

Why it happened:

During a service deployment, a network resource was not released properly causing the service to take longer than expected to start.

How we fixed it:

We cleaned up the resources manually to speed up the start time.

What we are doing to prevent it from happening again:

We are updating the cluster configuration so resources are available more quickly.

Posted Jul 12, 2022 - 09:20 UTC

Resolved
Between 17:19 UTC and 17:26 UTC we experienced an issue causing intermittent Visual build failures. We took remedial action and the problem was resolved. All services are fully operational.
Posted Jun 10, 2022 - 17:19 UTC