Sauce Labs Maintenance Window
We are experiencing intermittent issues with iOS Simulators and MacOS desktop browser tests in our US-West data center, caused by a third-party service disruption. Our engineering team is actively coordinating with the provider to restore full service.

2026-May-13 Resolved Service Incident

Incident Report for Sauce Labs

Postmortem

Dates:

Wednesday, May 13th 2026, 18:47 UTC - Friday, May 15th 2026, 09:23 UTC.

What happened:

Customers were unable to access test run summaries for Real Device Cloud (RDC) jobs because events stopped publishing to the jobs Kafka topic in US-EAST.

Why it happened:

An authentication key used by the message producer unexpectedly lost its permissions during an account cleanup.

How we fixed it:

Manually restored the required permissions to re-establish the connection and resume service.

What we are doing to prevent it from happening again:

Migrating to a permanent service account, implementing a Dead Letter Queue (DLQ) for the jobs Kafka topic, and replaying the missing events to restore customer data.

Posted May 26, 2026 - 15:08 UTC

Resolved

Between May 13th 18:47 UTC and May 15th 9:23 UTC, we experienced test details not appearing in the dashboard of the US-East Data Center. This issue has been resolved. All services are fully operational.
Posted May 21, 2026 - 14:53 UTC