Sauce Labs Maintenance Windows for Sauce Labs
Customers may experience intermittent errors during automated browser and virtual mobile device tests in our US-West-1 datacenter. We are closely monitoring and investigating the affected services.
2022-July-25 Resolved Service Incident
Incident Report for Sauce Labs
Postmortem

Dates:

Monday July 25th 2022, 14:45 - 19:15 UTC

What happened:

There were failures download iOS apps on our TestFairy platform

Why it happened:

A misconfigured endpoint failed to return the necessary parameters required by an iOS device to download and install apps.

How we fixed it:

We restored the endpoint that handled iOS specific downloads 

What we are doing to prevent it from happening again:

We’re creating automated tests that will detect download failures. Moreover, we will expose download failures from the download page.

Posted Aug 04, 2022 - 12:57 UTC

Resolved
Between 14:45 UTC and 19:45 UTC we experienced an issue causing intermittent downloading failures with our Test Fairy/Mobile Beta Testing platform. We took remedial action and the problem was resolved. All services are fully operational.
Posted Jul 25, 2022 - 14:30 UTC