Sauce Labs Maintenance Windows for Sauce Labs
Sauce Labs has consolidated onto one status page for all data centers.

The old status pages for US-West, US-East and EU-Central are still available to be able to view incident history. Anyone who was subscribed to notifications from one of the old status pages has been migrated onto this consolidated page. If you received an email saying that you had been unsubscribed from notifications, that was from one of the old pages and can be disregarded.

If you would like to select which components that you receive notifications for (e.g. if you are only interested in receiving notifications about incidents affecting Real Device Testing), you can access the subscription management page by clicking "Subscribe To Updates" above and enter the email address you are subscribed with. Additionally there is a "Manage Your Subscription" link on any email you will receive from the status page going forward.
2021-March-19 Service Incident
Incident Report for Sauce Labs
Postmortem

Dates:

Friday, March 19 2021, 16:39 - 20:51 UTC

What happened:

The “Legacy RDC” button did not appear in the navigation interface for real device tests running in the US-West-1 and EU-Central-1 data centers. Affected users were not able to access the Legacy RDC platform through the application.

Why it happened:

The Legacy RDC button was removed from navigation for users who don’t use the legacy RDC platform. Because of an error the change affected more users than originally intended.

How we fixed it:

The Legacy RDC button was restored back for all users.

What we are doing to prevent it from happening again:

We have made changes to the release process for similar updates by increasing the length of the pre-release window and the scope of our automated tests.

Posted Mar 25, 2021 - 18:21 UTC

Resolved
The Legacy RDC button is now available again. All services fully operational.
Posted Mar 19, 2021 - 20:50 UTC
Update
We are still working on bringing back the Legacy RDC button. As a workaround you can navigate to https://api.us-west-1.saucelabs.com/encore/signup/test_object
Posted Mar 19, 2021 - 18:57 UTC
Identified
Legacy RDC link on our UI is missing. We are taking remedial action.
Posted Mar 19, 2021 - 18:37 UTC
This incident affected: Legacy RDC UI.