Sauce Labs Maintenance Windows for Sauce Labs
We are seeing issues running automated tests in our Apac-Southeast-1 Data Center, we are currently investigating.

2022-June-08 Resolved Service Incident
Incident Report for Sauce Labs
Postmortem

Dates:

Wednesday June 8th 2022, 14:12 to 16:46 UTC

What happened:

Approximately 25% of Sauce Connect tunnel creations were erroring in our EU-Central-1 data center

Why it happened:

An improperly configured resource was added to the pool of Sauce Connect servers.

How we fixed it:

The misconfigured resource was removed from the pool of Sauce Connect servers.

What we are doing to prevent it from happening again:

Documentation and processes around configuring and deploying new Sauce Connect servers has been improved and peer reviewed.

Posted Jul 04, 2022 - 09:04 UTC

Resolved
EU-Central-1 Sauce Connect Tunnels were unable to start about ~25% of the time on Jun 8th 2:00 UTC to 14:00 UTC 2022. We took remedial action and all services are fully operational.
Posted Jun 08, 2022 - 08:30 UTC