Sauce Labs Maintenance Window
We are aware of an ongoing issue preventing logins to App Distribution when using Single Sign-On (SSO). We are actively investigating..

2025-November-19 Service Incident

Incident Report for Sauce Labs

Postmortem

Dates:

Wednesday, November 19th 2025, 09:00 UTC – Thursday, November 20th 2025, 21:00 UTC

What happened:

Following a scheduled maintenance deployment, a subset of customers utilising Single Sign-On (SSO) were unable to log in to the platform. While the application remained up and running, authentication requests for these specific accounts were rejected, preventing access to the application.

Why it happened:

A major backend infrastructure upgrade aimed at improving performance and security, inadvertently caused the incident. The new authentication system's default settings were incompatible with existing customer SSO configurations, leading to valid login attempts being incorrectly rejected.

How we fixed it:

To restore immediate access, we reverted the authentication processing logic to its previous state, ensuring full compatibility with all existing customer configurations.

What we are doing to prevent it from happening again:

We are adding enhanced monitoring for authentication success rates and updating pre-deployment testing to cover more legacy SSO configurations for seamless compatibility.

Posted Jan 05, 2026 - 17:27 UTC

Resolved

Earlier today, customers were unable to log in to App Distribution via SSO.
After taking remedial action, users are now able to login successfully. This incident is resolved.
Posted Nov 19, 2025 - 22:17 UTC

Identified

We identified the root cause and are now working to restore the service.
Posted Nov 19, 2025 - 19:36 UTC

Investigating

We are currently receiving reports indicating that customers are unable to log in to App Distribution using Single Sign-On (SSO). Our team is actively investigating the root cause and working toward a resolution.
Posted Nov 19, 2025 - 18:54 UTC
This incident affected: Mobile App Distribution (Mobile App Distribution Platform, Mobile App Distribution UI).