Sauce Labs will have a four hour previously scheduled maintenance window on Wednesday, July 10th, starting at 04:00 UTC and ending at 08:00 UTC. During this maintenance window, we will be making updates to our infrastructure and services in our US West data center. These maintenance actions may cause portions of the service (including running automated and manual tests) to be unavailable for up to four hours.
Get email notifications whenever Sauce Labs creates, updates or resolves an incident.
Get text message notifications whenever Sauce Labs creates or resolves an incident.
Get incident updates and maintenance status messages in Slack.
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 17, 2023 - 17:00 UTC
Scheduled
Sauce Labs will have a two hour previously scheduled maintenance window on June 17th, starting at 17:00 UTC and ending at 19:00 UTC. During this maintenance window, we will be making updates to our infrastructure and services in our US data center. These maintenance actions may cause portions of the service (including running automated and manual tests) to be unavailable for up to two hours.
Posted Mar 28, 2023 - 04:31 UTC
This scheduled maintenance affected: Automated Browser Testing (US-West), Automated Virtual Mobile Device Testing (US-West), Automated Real Device Testing (US-West, US-East), Live Browser Testing (US-West), Live Virtual Mobile Device Testing (US-West), Live Real Device Testing (US-West, US-East), API Testing (US-West), Sauce Connect (US-West), Visual Testing (Visual Testing Hub, Visual Testing Infrastructure, Visual Testing REST API, Legacy Visual Testing (Screener) UI), Sauce Labs REST API (US-West), Sauce Labs Dashboard (US-West), Insights (US-West), Billing (US-West), Other (saucelabs.com), IPSec VPN (US-West), and Native Framework Mobile App Testing (US-West).