Sauce Labs Maintenance Windows for Sauce Labs
We are currently performing maintenance that will affect the initiation of new Sauce Connect tunnel instances. The maintenance is expected to be completed by 2:00 PM PST. We appreciate your understanding and patience as we work to enhance our service.

2024-September-30 Resolved Service Incident

Incident Report for Sauce Labs

Postmortem

Dates:

Monday September 30 2024, 15:53 - 16:10 UTC

What happened:

The Sauce Labs WebUI in the EU Central 1 datacenter was inaccessible.

Why it happened:

The gateway in front of https://app.eu-central-1.saucelabs.com/ was misconfigured.

How we fixed it:

The gateway was rolled back to the previous working version.

What we are doing to prevent it from happening again:

Synthetic monitoring for https://app.eu-central-1.saucelabs.com/ has been improved.

Posted Apr 01, 2025 - 15:31 UTC

Resolved

Between 15:53 - 16:11 UTC, Sauce Labs dashboard was unavailable in our EU Data Center. The access has been restored and all services are operational.
Posted Sep 30, 2024 - 16:41 UTC