Sauce Labs Maintenance Windows for Sauce Labs
Our EU Central data center (RDC) will undergo unplanned but necessary power maintenance on June 19th, 2025, between 07:00 and 18:00 CEST (05:00–16:00 UTC). During this maintenance window, devices may experience brief service interruptions lasting up to 20–30 minutes. We are taking every measure to minimize impact and ensure full service restoration as quickly as possible. We appreciate your understanding and apologize for any inconvenience this may cause.

2022-August-10 Service Incident

Incident Report for Sauce Labs

Postmortem

Dates:

Wednesday August 10th 2022, 14:35 - 17:55 UTC

What happened:

We deployed a release that resulted in black screen errors by customers who tried to launch any new RDC Live Testing sessions for iOS 15+ devices.

Why it happened:

When deploying a release that was meant to address an issue with typing in iOS 16 we introduced an issue with receiving screen recording events in iOS 15+ devices due to the version of Xcode we upgraded to in the release. 

How we fixed it:

We rolled back the release and the version of Xcode. 

What we are doing to prevent it from happening again:

We are continuing to look into the original issue and will be improving our observability to better detect issues with LiveTesting.

Posted Aug 22, 2022 - 11:46 UTC

Resolved

We have identified the issue and deployed a fix. All services are fully operational.
Posted Aug 10, 2022 - 18:56 UTC

Investigating

We are experiencing issues with live tests on iOS 15+ real devices in our US West and EU Central Data Centers causing black screen on launch. We are currently investigating.
Posted Aug 10, 2022 - 17:51 UTC
This incident affected: Live Real Device Testing (US-West, EU-Central).