Sauce Labs Maintenance Windows for Sauce Labs
We are seeing issues running automated tests in our Apac-Southeast-1 Data Center, we are currently investigating.

2022-May-24 Service Incident
Incident Report for Sauce Labs
Postmortem

Dates:

Wednesday May 24th 2022, 08:05 - 08:42 UTC

What happened:

Sauce Connect tunnels intermittently failed to start in our eu-central-1 data center.

Why it happened:

Unusually high load caused our back-end systems to respond slower than usual.

How we fixed it:

The system restored its normal behavior after the load was decreased.

What we are doing to prevent it from happening again:

  • We are planning to improve our back-end system performance in EU-Central to be able to handle this workload
  • We will introduce stricter rate-limiting rules to ensure that an individual user cannot affect the system performance
Posted May 31, 2022 - 15:18 UTC

Resolved
Tunnels should now start normally in eu-central-1.
Posted May 24, 2022 - 09:15 UTC
Investigating
Tunnels in eu-central-1 are not starting, existing tunnels are not impacted. We are investigating and taking remedial action.
Posted May 24, 2022 - 08:43 UTC
This incident affected: Sauce Connect (EU-Central).