Sauce Labs Maintenance Windows for Sauce Labs
Customers may experience intermittent errors during automated browser and virtual mobile device tests in our US-West-1 datacenter. We are closely monitoring and investigating the affected services.
2022-June-21 Resolved Service Incident
Incident Report for Sauce Labs
Postmortem

Dates:

Tuesday June 21st 06:33 2022 - 07:16 2022 UTC

What happened:

The Sauce Labs dashboard was returning error 500 in all data centers.

Why it happened:

An outage in a third-party billing system caused an error displaying the Sauce Labs dashboard.

How we fixed it:

The third-party system recovered.

What we are doing to prevent it from happening again:

We are improving the way we handle different server errors and displaying error pages accordingly in the application.

Posted Jul 05, 2022 - 08:50 UTC

Resolved
Between 6:30 UTC and 7:15 UTC we experienced issues accessing the Sauce Labs Dashboard in all our Data Centers. This issue is now resolved, All services are fully operational.
Posted Jun 21, 2022 - 07:32 UTC