Sauce Labs Maintenance Window
We are aware of an ongoing issue preventing logins to App Distribution when using Single Sign-On (SSO). We are actively investigating..

2025-December-17 Resolved Service Incident

Incident Report for Sauce Labs

Postmortem

When it happened:

Wednesday, December 17th 2025, 10:37 UTC - Thursday, December 18th 2025, 11:59 UTC

What happened:

Applications were unable to be downloaded via Mobile App Distribution for a subset of customers.

Why it happened:

A product change combined with an increased and sustained load resulted in higher resource usage than anticipated, exceeding established limits for certain clients.

How we fixed it:

The service was rolled back to a stable version.

What we are doing to prevent it from happening again:

There are multiple improvements planned. 

  1. Improved monitoring & alerting, 
  2. Enhanced post-deployment validation
  3. Capacity planning forecasting
  4. More advanced communication where possible ahead of major changes
  5. Adding canary to the roll out process
Posted Jan 05, 2026 - 16:09 UTC

Resolved

Between 10:37 UTC December 17th and 11:59 UTC December 18th, we were experiencing issues downloading applications via Mobile App Distribution. This issue has been resolved. All services are fully operational.
Posted Dec 17, 2025 - 10:30 UTC