Sauce Labs Maintenance Windows for Sauce Labs
We are aware of and working to resolve intermittent WiFi connectivity and slowness issues affecting Android Real Devices in our US-West-1 data center. Please contact our Support team should you wish to report any such issues.

2021-September-13 Service Incident
Incident Report for Sauce Labs
Postmortem

Dates:

Monday September 13th 2021, 06:00 - 07:03 UTC

What happened:

Services in our US-West-1 data center, including Sauce Connect tunnels, the Sauce Labs REST API, and the Sauce Labs dashboard were not starting.

Why it happened:

An update to the database used to establish connections by one of our microservices had not been fully applied. 

How we fixed it:

The credentials used to establish a database connection were reapplied.

What we are doing to prevent it from happening again:

Monitoring mechanisms for the affected database were disabled. API monitoring tests will now be run more frequently so that we can detect a similar issue in the future with less delay.

Posted Sep 21, 2021 - 10:18 UTC

Resolved
This incident has been resolved, all services are fully operational.
Posted Sep 13, 2021 - 07:39 UTC
Identified
We have identified the issue and taken action. Services are beginning to recover but we are still monitoring the issue.
Posted Sep 13, 2021 - 07:17 UTC
Update
We are continuing to investigate this issue.
Posted Sep 13, 2021 - 06:55 UTC
Investigating
Automated Browser, Virtual Mobile Device and Real Device tests are not starting. In addition, Sauce Connect Tunnels are not starting, the Sauce Labs REST API is not responding, and the Sauce Labs dashboard is not loading, all in our US-West-1 datacenter.
Posted Sep 13, 2021 - 06:53 UTC
This incident affected: Live Virtual Mobile Device Testing (US-West), Sauce Labs UI (US-West), Live Browser Testing (US-West), Automated Browser Testing (US-West), Sauce Labs REST API (US-West), Sauce Connect (US-West), Automated Real Device Testing (US-West), Automated Virtual Mobile Device Testing (US-West), and Live Real Device Testing (US-West).