Sauce Labs Maintenance Windows for Sauce Labs
Sauce Labs will have a four hour previously scheduled maintenance window on Wednesday, July 10th, starting at 04:00 UTC and ending at 08:00 UTC. During this maintenance window, we will be making updates to our infrastructure and services in our US West data center. These maintenance actions may cause portions of the service (including running automated and manual tests) to be unavailable for up to four hours.
2024-February-29 Service Incident
Incident Report for Sauce Labs
Postmortem

Dates:

Thursday February 29th 2024, 16:25 UTC - Friday March 1st, 00:15 UTC

What happened:

iOS Simulators in our OS-West-1 data center intermittently experienced longer startup times and in some cases failed to acquire a session, resulting in test failure.

Why it happened:

An increase in utilization throughout the Mac Cloud created additional pressure and lack of availability for some images, which resulted in higher-than-normal startup times.  In some cases, the startup times were high enough to cause test failure due to abandonment of the session.

How we fixed it:

Burst capacity was leveraged to provide some relief.  Later, utilization decreased to normal levels.

What we are doing to prevent it from happening again:

We are working to both increase capacity and decrease startup times for iOS Simulators.

Posted Mar 12, 2024 - 12:32 UTC

Resolved
After taking remedial action error rates in Desktop and Virtual Device tests are back to normal levels. This incident is resolved
Posted Feb 29, 2024 - 23:19 UTC
Update
We are currently seeing elevated error rates in Desktop and Virtual device tests in the US-West-1 datacenter. We are still investigating.
Posted Feb 29, 2024 - 22:02 UTC
Investigating
We are currently seeing elevated error rates in Desktop and Virtual device tests in the US-West-1 datacenter. We are currently investigating.
Posted Feb 29, 2024 - 20:43 UTC
This incident affected: Automated Browser Testing (US-West) and Automated Virtual Mobile Device Testing (US-West).