Sauce Labs Maintenance Windows for Sauce Labs
We are currently performing maintenance that will affect the initiation of new Sauce Connect tunnel instances. The maintenance is expected to be completed by 2:00 PM PST. We appreciate your understanding and patience as we work to enhance our service.

2025-Feb-17 Resolved Service Incident

Incident Report for Sauce Labs

Postmortem

Dates:

Wednesday February 17th 2023, 12:52 - 13:53 UTC

What happened:

Real Device tests in EU-Central-1 datacenter were experiencing issues reaching internet destinations.

Why it happened:

A new internet provider was introduced that was experiencing issues with their network..

How we fixed it:

A rollback was executed to move traffic off of the affected internet provider.

What we are doing to prevent it from happening again:

We engaged the provider and they corrected configuration issues with their network.

Posted Apr 01, 2025 - 16:33 UTC

Resolved

Between 12:52 and 13:53 UTC, some Real Device tests in EU-Central-1 Data center experienced failures reaching internet destinations because of an issue on an upstream ISP network. We have identified the issue and taken remedial action.
Posted Feb 17, 2025 - 18:44 UTC