Sauce Labs Maintenance Windows for Sauce Labs
Customers may experience intermittent errors during automated browser and virtual mobile device tests in our US-West-1 datacenter. We are closely monitoring and investigating the affected services.
2022-June-7 Resolved Service Incident
Incident Report for Sauce Labs
Postmortem

Dates:

Tuesday June 7th 2022, 13:59 - 15:51 UTC

What happened:

The Sauce Labs dashboard was intermittently returning 404 errors in our US-West-1 data center.

Why it happened:

A deployment with an invalid configuration was made, which changed how the affected API was exposed and routed requests incorrectly, resulting in 404 errors. 

How we fixed it:

We rolled back to the last working version.

What we are doing to prevent it from happening again:

We are improving the way we handle API failures in our UI to make it more resilient. Monitoring of the affected API will be improved to cover all endpoints.

Posted Jul 12, 2022 - 09:23 UTC

Resolved
Between 17:10 UTC and 20:08 we saw an elevated spike of Infrastructure Errors on our platform impacting our macOS and iOS VMs on our us-west-1 data center. After debugging and finding the root cause, we saw this error rate fall back to normal levels. All services are fully operational.
Posted Jun 08, 2022 - 17:00 UTC