Sauce Labs Maintenance Windows for Sauce Labs
Sauce Labs has consolidated onto one status page for all data centers.

The old status pages for US-West, US-East and EU-Central are still available to be able to view incident history. Anyone who was subscribed to notifications from one of the old status pages has been migrated onto this consolidated page. If you received an email saying that you had been unsubscribed from notifications, that was from one of the old pages and can be disregarded.

If you would like to select which components that you receive notifications for (e.g. if you are only interested in receiving notifications about incidents affecting Real Device Testing), you can access the subscription management page by clicking "Subscribe To Updates" above and enter the email address you are subscribed with. Additionally there is a "Manage Your Subscription" link on any email you will receive from the status page going forward.
2021-April-13 Service Incident
Incident Report for Sauce Labs
Postmortem

Dates:

Tuesday, April 13, 09:06 - 09:32 UTC

What happened:

The dashboard for the Sauce Labs US and EU datacenters was non-operational and returned an error page. Requests sent by clients to the Sauce Extended Team Management REST API were also affected.

Why it happened:

We deployed a new version of one of our services and immediately noticed an issue. We performed an immediate rollback but reverted to an older version in error, which prevented the service from booting.

How we fixed it:

We did a rollback to the most up-to-date working version. 

What we are doing to prevent it from happening again:

We have automated our rollback process so that the probability of a human error in this process has been decreased.

Posted Apr 14, 2021 - 20:05 UTC

Resolved
The Sauce Labs dashboard is now responding normally. This incident is resolved.
Posted Apr 13, 2021 - 09:34 UTC
Investigating
The Sauce Labs dashboard is returning Error 500 in our US-West-1 and EU-Central-1 datacenters. We are investigating.
Posted Apr 13, 2021 - 09:28 UTC
This incident affected: Sauce Labs UI (US-West, EU-Central).