Sauce Labs Maintenance Windows for Sauce Labs
We are currently performing maintenance that will affect the initiation of new Sauce Connect tunnel instances. The maintenance is expected to be completed by 2:00 PM PST. We appreciate your understanding and patience as we work to enhance our service.

2024-December-12 Resolved Service Incident

Incident Report for Sauce Labs

Postmortem

Dates:

Thursday December 12 2024, 12:40 - 13:30 UTC

What happened:

Video recordings for Android Real Device tests were not showing in test results.

Why it happened:

A code deployment contained a broken dependency.

How we fixed it:

A rollback was executed to the previous known working version.

What we are doing to prevent it from happening again:

A check for broken dependencies was added to the deployment.

Posted Apr 01, 2025 - 15:49 UTC

Resolved

Between 12:40 UTC and 13:20 UTC, Video recordings were missing in test reports for Android tests, affected all regions . We have identified the issue and taken remedial action.
Posted Dec 12, 2024 - 13:59 UTC
This incident affected: Automated Real Device Testing (US-West, EU-Central, US-East), Live Real Device Testing (US-West, EU-Central, US-East), and Native Framework Mobile App Testing (US-West, EU-Central, US-East).