Sauce Labs Maintenance Windows for Sauce Labs
We are currently performing maintenance that will affect the initiation of new Sauce Connect tunnel instances. The maintenance is expected to be completed by 2:00 PM PST. We appreciate your understanding and patience as we work to enhance our service.

2024-December-18 Service Incident

Incident Report for Sauce Labs

Postmortem

Dates:

Wednesday December 18th 2024, 09:05 - 11:31 UTC

What happened:

Customers were unable to purchase self-service plans through the billing page.

Why it happened:

Breaking changes were introduced between our billing service client SDK and the third-party billing provider.

How we fixed it:

The SDK for the third-party billing provider was updated in our service.

What we are doing to prevent it from happening again:

We’re working with the third-party billing provider to better understand their versioning practices to ensure we remain inline with them.

Posted Apr 01, 2025 - 15:53 UTC

Resolved

Customers are able to purchase Self-Service plans from our dashboard again. This issue is resolved.
Posted Dec 18, 2024 - 11:57 UTC

Investigating

There is currently an issue with purchasing self-service plans from our dashboard, We are investigating.
Posted Dec 18, 2024 - 10:43 UTC
This incident affected: Billing (US-West, EU-Central).