Sauce Labs Maintenance Window
Starting July 31, 2026, Sauce Labs will no longer accept traffic from Sauce Connect 4 . Customers must upgrade to Sauce Connect 5 to continue using Sauce Connect Proxy.

2026-August-07 Service Incident

Incident Report for Sauce Labs

Resolved

After taking remedial action, Virtual Desktop tests are starting successfully in the US-West-1 Data center. All services are fully operational. We are closely monitoring the situation
Posted Aug 07, 2026 - 13:06 UTC

Investigating

We are currently seeing elevated error rates for virtual desktop tests in the US-West-1 datacenter. We are currently investigating.
Posted Aug 07, 2026 - 12:08 UTC