Sauce Labs Maintenance Windows for Sauce Labs
Customers may experience intermittent errors during automated browser and virtual mobile device tests in our US-West-1 datacenter. We are closely monitoring and investigating the affected services.
2023-January-26 Service Incident
Incident Report for Sauce Labs
Postmortem

Dates:

Thursday January 26th 2023, 13:40 - Friday January 27th 00:14 UTC

What happened:

Customers could not sign up using Google Auth and GitHub in US and EU DCs.

Account creation via email address was unaffected and operating normally.

Why it happened:

We deployed a change to OAuth that placed newly created accounts in a freemium org type. There was a bug in this new workflow that was not caught in our test coverage and it was deployed to production. 

How we fixed it:

We rolled back to the previous version and signing up using Google Auth and GitHub in US and EU DCs was restored. 

What we are doing to prevent it from happening again:

We are adding metrics to give us better insight into the failure rate for user sign-ups that use the OAuth flow as well as expanding our test coverage.

Posted Feb 23, 2023 - 17:28 UTC

Resolved
After taking remedial action, account sign-up via Google Auth and GitHub is available in both US-West-1 and EU-Central-1 Datacenters.
This issue is now resolved.
Posted Jan 26, 2023 - 23:19 UTC
Investigating
We are currently experiencing an issue with the Account Sign-Up process via Google Auth and GitHub in the US and EU Data Centers. Account creation via email sign-up is available. We are currently investigating.
Posted Jan 26, 2023 - 23:01 UTC
This incident affected: Sauce Labs Dashboard (US-West, EU-Central).