Sauce Labs Maintenance Window
We are currently experiencing a slight reduction in available public and private iOS devices in the EU-Central Data Center. We expect to restore full availability for all iOS users in the EU-Central Data Center by tomorrow, Thursday, July 3, 2025, end of day

2024-Feb-2 Resolved Service Incident

Incident Report for Sauce Labs

Postmortem

Dates:

Thursday February 1st 2024, 16:00 - 17:00 UTC

What happened:

Some customers were unable to start tunnels with Sauce Connect 5.

Why it happened:

A new SC Tunnel image was released to production that contained a bug preventing some tunnels from starting.

How we fixed it:

We rolled back to the previous version of the image.

What we are doing to prevent it from happening again:

We’re investigating additional testing practices prior to release for specific edge case configurations.  Additionally, we are updating our alerting to be clearer on the affected component.

Posted Mar 05, 2024 - 16:03 UTC

Resolved

Approximately between 00:00 and 01:00 UTC, customers may have experienced tunnel creation failures in our EU-Central and US-West data centers. This issue has now been resolved.
Posted Feb 02, 2024 - 00:00 UTC