Sauce Labs Maintenance Windows for Sauce Labs
We are aware of and working to resolve intermittent WiFi connectivity and slowness issues affecting Android Real Devices in our US-West-1 data center. Please contact our Support team should you wish to report any such issues.

2021-September-02 Service Incident
Incident Report for Sauce Labs
Postmortem

Dates:

Thursday September 2nd 2021, 13:09 - 22:26 UTC

What happened:

Customers running live tests were presented with a 401 error after a few minutes.

Why it happened:

The timeout settings between the different layers of our application were not in sync, so users were being redirected to a 401 screen at unexpected times.

How we fixed it:

We have synchronized the timeout values.

What we are doing to prevent it from happening again:

We are making sure that the implementation throughout the different layers matches the desired expectations and that we have proper validation in place for longer sessions.

Posted Sep 08, 2021 - 18:30 UTC

Resolved
We have identified the issue and deployed a fix. Live Real Device tests are working as expected.
Posted Sep 02, 2021 - 22:28 UTC
Update
Live Real Device test users may continue to see intermittent "401 Clearance Needed" errors on UI. We are still investigating
Posted Sep 02, 2021 - 19:32 UTC
Update
Live RDC test users might run into intermittent "401 Clearance Needed" errors. We continue to investigate.
Posted Sep 02, 2021 - 15:57 UTC
Investigating
While running a Live RDC test users may see the error, “401 Clearance Needed” and the Live test will halt. We are investigating.
Posted Sep 02, 2021 - 13:22 UTC
This incident affected: Live Real Device Testing (US-West, EU-Central).