Sauce Labs Maintenance Window
We are experiencing intermittent issues with iOS Simulators and MacOS desktop browser tests in our US-West data center, caused by a third-party service disruption. Our engineering team is actively coordinating with the provider to restore full service.

2025-October-28 Resolved Service Incident

Incident Report for Sauce Labs

Postmortem

Dates:

Tuesday, October 28th 2025, 14:03 UTC - 15:18 UTC (primary incident)
Tuesday, October 28th 2025, 15:18 UTC - Thursday, October 30th 2025, 8:25 UTC (~1% of devices impacted window)

What happened:

Test executions using the 'stable' Appium version gradually decreased in the US-West-1, US-East-4, and EU-Central-1 data centers.

Why it happened:

A product defect was introduced which caused tests using the stable Appium version to fail immediately upon creation.

How we fixed it:

We preformed a rollback to a previous version on the majority of devices on Tuesday, October 28th 2025, 15:18 UTC, With a full service restoration across all devices completed on Thursday, October 30th 2025, 8:25 UTC.

What we are doing to prevent it from happening again:

We have improved monitoring & alerting and enhanced our post-deployment validation processes.

Posted Dec 11, 2025 - 16:31 UTC

Resolved

Between 14:07 UTC and 15:25 UTC, we experienced a high error rate for automated and manual Real Device tests in the US-West, US-East, and EU data centers. This issue has been resolved. All services are fully operational.
Posted Oct 28, 2025 - 16:13 UTC