Sauce Labs Maintenance Window
We are aware of an ongoing issue preventing logins to App Distribution when using Single Sign-On (SSO). We are actively investigating..

2025-November-3 Resolved Service Incident

Incident Report for Sauce Labs

Postmortem

Dates:

Monday November 3 2025, 12:40 UTC - 14:25 UTC.

What happened:

The Sauce Labs dashboard for Insights and Test Results was unresponsive, causing issues showing test results and related information.

Why it happened:

A data store for some components of the dashboard experienced unusually high load, resulting in an unresponsive service.

How we fixed it:

The issue was resolved by increasing the resources for the affected data store service.

What we are doing to prevent it from happening again:

Support for the 3rd party vendor's logging and metrics tools has been improved.

Posted Dec 11, 2025 - 17:23 UTC

Resolved

Access to test results was interrupted in our EU Data Center from 12:40 UTC to 14:25 UTC. The issue has been identified and resolved.
Posted Nov 03, 2025 - 16:00 UTC