Sauce Labs Partially Degraded Service
We are currently experiencing a slight reduction in available public and private iOS devices in the EU-Central Data Center. We expect to restore full availability for all iOS users in the EU-Central Data Center by tomorrow, Thursday, July 3, 2025, end of day

2025-January-8 Service Incident

Incident Report for Sauce Labs

Postmortem

Dates:

Wednesday 8 January 2025, 11:00 - 12:25 UTC

What happened:

We were experiencing intermittent issues with Virtual device tests missing test assets in the US-West-1 region  

Why it happened:

The asset uploader service was experiencing Http errors uploading assets to our backend storage.

How we fixed it:

The 3rd-party provider resolved an issue with their infrastructure. 

What we are doing to prevent it from happening again:

We are improving the caching and retry logic of the asset uploader service to prevent further occurrence.

Posted Apr 01, 2025 - 16:17 UTC

Resolved

After taking remedial action, test assets are being retained successfully in all tests. This incident is resolved.
Posted Jan 08, 2025 - 12:54 UTC

Update

We are currently seeing intermittent issues with test assets not being retained for Virtual device tests in our US-West-1 data center. We are investigating.
Posted Jan 08, 2025 - 12:44 UTC

Update

We are continuing to investigate this issue.
Posted Jan 08, 2025 - 12:41 UTC

Update

We are currently seeing Live and Automated test results are not being retained for Virtual Device tests intermittently in our US-West-1 data centers. We are investigating.
Posted Jan 08, 2025 - 11:56 UTC

Investigating

We are currently seeing Live and automated test results are not being retained intermittently in our US-West-1 data centers. We are investigating.
Posted Jan 08, 2025 - 11:40 UTC
This incident affected: Automated Browser Testing (US-West), Automated Virtual Mobile Device Testing (US-West), Automated Real Device Testing (US-West), Live Browser Testing (US-West), Live Virtual Mobile Device Testing (US-West), Live Real Device Testing (US-West), Insights (US-West), and US-West.