We are currently performing maintenance that will affect the initiation of new Sauce Connect tunnel instances. The maintenance is expected to be completed by 2:00 PM PST. We appreciate your understanding and patience as we work to enhance our service.
Get email notifications whenever Sauce Labs creates, updates or resolves an incident.
Get text message notifications whenever Sauce Labs creates or resolves an incident.
Get incident updates and maintenance status messages in Slack.
App storage errors have been resolved. All services are fully operational.
Posted Mar 27, 2025 - 14:35 UTC
Investigating
We are seeing failures due to issue with our storage service affecting Virtual and Real Device Cloud as well as any saucectl and Mobile App Distribution in our US-West Data Center. We are investigating
Posted Mar 27, 2025 - 14:23 UTC
This incident affected: Automated Virtual Mobile Device Testing (US-West), Automated Real Device Testing (US-West), Live Virtual Mobile Device Testing (US-West), Live Real Device Testing (US-West), Sauce Labs REST API (US-West), Native Framework Mobile App Testing (US-West), and Mobile App Distribution (TestFairy) (TestFairy Platform).