Sauce Labs Maintenance Windows for Sauce Labs
Sauce Labs will have a four hour previously scheduled maintenance window on Wednesday, July 10th, starting at 04:00 UTC and ending at 08:00 UTC. During this maintenance window, we will be making updates to our infrastructure and services in our US West data center. These maintenance actions may cause portions of the service (including running automated and manual tests) to be unavailable for up to four hours.
2024-February-12 Service Incident
Incident Report for Sauce Labs
Postmortem

Dates:

Sunday February 11th 2024, 13:35 - Monday February 12th 2024, 09:00 UTC

What happened:

Over the course of the incident, iOS 17 device availability decreased until all devices were unavailable.

Why it happened:

A change in behavior in Xcode resulted in non-exiting child processes that eventually caused the app to become unresponsive.

How we fixed it:

Child processes were reaped across the service’s fleet.

What we are doing to prevent it from happening again:

We are working to improve the reliability of services involved in managing iOS 17 real devices.

Posted Mar 05, 2024 - 16:12 UTC

Resolved
After taking remedial action, we are seeing iOS 17 Real devices are now available again. This incident is resolved.
Posted Feb 12, 2024 - 09:01 UTC
Investigating
iOS 17 Real devices are currently unavailable in the US-West-1 and EU-Central-1 data centers. We are investigating.
Posted Feb 12, 2024 - 08:44 UTC
This incident affected: Automated Real Device Testing (US-West, EU-Central), Live Real Device Testing (US-West, EU-Central), and Native Framework Mobile App Testing (US-West, EU-Central).