Sauce Labs Maintenance Windows for Sauce Labs
We are experiencing an intermittent issue in our US-West-1 datacenter that causes elevated wait times and error rates when starting desktop browser and virtual mobile device tests. Until we address the underlying causes of this issue, we expect this issue to continue to reoccur. We will post incidents here on our status page as each instance of this issue occurs whilst we continue to work to address the underlying cause.
2022-December-16 Resolved Service Incident
Incident Report for Sauce Labs
Postmortem

Dates:

Friday December 16th 2022, 15:48 - 16:05 UTC

What happened:

Automated and Live mobile device testing was completely unavailable for approximately 20 minutes, preventing customers from starting new sessions.

Why it happened:

The service responsible for running mobile tests was accidentally deleted during a routine deployment due to human error. The deployment pipeline had a delete stage that was accidentally clicked during the deployment.   

How we fixed it:

As soon as the problem was identified, the latest deployment for both DCs was re-triggered, re-deploying the service that had been previously deleted.

What we are doing to prevent it from happening again:

The team responsible for this service and its pipeline has removed this stage (delete deployment) as an option from the deployment pipeline.

Posted Jan 24, 2023 - 10:05 UTC

Resolved
Between 15:48 UTC and 16:05 UTC users were unable to reach our Real Device Cloud on US-West-1 and EU-Central-1 Data Centers. This issue is now resolved, all services are fully operational.
Posted Dec 16, 2022 - 16:00 UTC