Sauce Labs Maintenance Windows for Sauce Labs
We are aware of and working to resolve intermittent WiFi connectivity and slowness issues affecting Android Real Devices in our US-West-1 data center. During a maintenance window on September 25, we made changes to our wireless infrastructure which has greatly improved the situation, but we are still monitoring and working on further improvements. Please contact our Support team should you wish to report any such issues.

2021-Oct-12 Service Incident
Incident Report for Sauce Labs
Postmortem

Dates:

Tuesday October 12 2021, 13:45 - 15:45 UTC

What happened:

Customers received errors when attempting to start new TestCafe/Cypress/Espresso/XCUITest tests.

Why it happened:

We upgraded a third party service, which introduced a regression.

How we fixed it:

We rolled the third party service back to the previous version.

What we are doing to prevent it from happening again:

We’re adding additional monitoring tests to detect issues such as this in the future.

Posted Oct 13, 2021 - 14:38 UTC

Resolved
We have taken remedial action and tests are passing as intended. All services are fully operational.
Posted Oct 12, 2021 - 16:06 UTC
Investigating
Test runs using SauceCtl are failing with 400 error on US and EU DataCenters. We are investigating
Posted Oct 12, 2021 - 14:31 UTC
This incident affected: Native Mobile App Testing (US-West, EU-Central).