Sauce Labs Maintenance Windows for Sauce Labs
Sauce Labs will have a four hour previously scheduled maintenance window on Wednesday, July 10th, starting at 04:00 UTC and ending at 08:00 UTC. During this maintenance window, we will be making updates to our infrastructure and services in our US West data center. These maintenance actions may cause portions of the service (including running automated and manual tests) to be unavailable for up to four hours.
2024-March-5 Service Incident
Incident Report for Sauce Labs
Resolved
This incident has been resolved.
Posted Mar 06, 2024 - 09:52 UTC
Monitoring
After taking remedial action, the redirect is working as expected. We are currently monitoring.
Posted Mar 05, 2024 - 21:57 UTC
Investigating
We've identified redirect issues for Mobile Beta login on our Dashboard in both US-West-1 and EU-Central-1 Datacenters. Investigation is underway.
Posted Mar 05, 2024 - 21:12 UTC
This incident affected: Mobile Beta Testing (TestFairy) (TestFairy Platform, TestFairy UI).