We are experiencing intermittent issues with iOS Simulators and MacOS desktop browser tests in our US-West data center, caused by a third-party service disruption. Our engineering team is actively coordinating with the provider to restore full service.
After taking remedial action and monitoring the situation, we are seeing iOS ARM application tests perform as expected in the EU Data Center. All services are fully operational.
Posted Jul 14, 2026 - 20:23 UTC
Update
We are continuing to monitor for any further issues.
Posted Jul 14, 2026 - 19:11 UTC
Monitoring
We have deployed a fix for this issue. Tests should now be performing as expected in the EU Central 1 data center. We are monitoring.
Posted Jul 14, 2026 - 18:56 UTC
Update
App downloads are taking longer than expected when these infrastructure errors are seen. We are continuing to investigate.
Posted Jul 14, 2026 - 18:05 UTC
Investigating
We are experiencing an issue in the EU Central 1 data center, where iOS ARM Simulator app tests fail with infrastructure errors. We are investigating.
Posted Jul 14, 2026 - 17:19 UTC
This incident affected: Automated Virtual Mobile Device Testing (EU-Central) and Live Virtual Mobile Device Testing (EU-Central).