Sauce Labs Maintenance Windows for Sauce Labs
We are currently aware of an ongoing issue impacting the Talkback functionality on our Real Device Cloud. Our team is actively working to resolve this as quickly as possible.
2023-November-1 Service Incident
Incident Report for Sauce Labs
Postmortem

Dates:

Friday November 1st 2023, 10:15 - 18:00 UTC

What happened:

An individual customer was continuously running a large number of misconfigured tests, impacting the overall error rate in the US-West region and ultimately triggering our alerting system. Though the error rate alerting threshold was surpassed, no other customer tests were impacted.

Why it happened:

Due to the individual customer’s misconfiguration, all tests they ran failed to start. Our test validation service did not properly identify the misconfiguration, causing VMs to be allocated to them. The large number of failing tests tripped our alerting system, though only the individual customer was impacted.

How we fixed it:

We worked with the individual customer to stop and reconfigure their tests.

What we are doing to prevent it from happening again:

We are enhancing our test configuration validation to better inform customers of these issues before a VM is allocated to a test that will ultimately fail. We are also improving our visibility into test errors, to better identify and monitor individual customer issues versus overall system issues.

Posted Nov 28, 2023 - 10:11 UTC

Resolved
After taking remedial action, error rates have decreased for Desktop Browser tests in our US-West datacenter. The issue is now resolved.
Posted Nov 01, 2023 - 13:45 UTC
Investigating
Error rates in our US-West region are elevated for Desktop Browser tests, particularly on Windows. We are investigating.
Posted Nov 01, 2023 - 12:33 UTC
This incident affected: Automated Browser Testing (US-West) and Live Browser Testing (US-West).