Sauce Labs Maintenance Window
We are currently experiencing reduction in available public and private Android devices in the US-West Data Center. We're working to restore full service for all Android users as quickly as possible.

2025-November-04 Service Incident

Incident Report for Sauce Labs

Resolved

The access to Sauce Labs Home, Test Results, Insights, API has been restored. All services are fully operational.
Posted Nov 04, 2025 - 11:10 UTC

Investigating

We are currently seeing issues accessing the Sauce Home, Insights, Test Results, API in EU-Central-1. We are investigating.
Posted Nov 04, 2025 - 08:02 UTC
This incident affected: Insights (EU-Central) and Sauce Labs Dashboard (EU-Central).