Sauce Labs Maintenance Window
We are experiencing intermittent issues with iOS Simulators and MacOS desktop browser tests in our US-West data center, caused by a third-party service disruption. Our engineering team is actively coordinating with the provider to restore full service.

2026-March-19 Service Incident

Incident Report for Sauce Labs

Postmortem

Dates:

Wednesday, March 19 2026, 04:45 UTC - 10:47 UTC.

What happened:

Approximately 15% of iOS devices in our US-West data center were temporarily unavailable for customer test sessions due to failed internet connectivity checks.

Why it happened:

An automated wireless network optimization feature adjusted transmit power levels on access points serving the affected devices, degrading wireless connectivity and causing devices to fail their availability checks.

How we fixed it:

The affected access points were identified and restarted, restoring normal wireless connectivity.

What we are doing to prevent it from happening again:

Evaluation of the automated optimization tools and a monitoring improvement.

Posted Apr 15, 2026 - 19:16 UTC

Resolved

This incident has been resolved and our services are fully operational.
Posted Mar 19, 2026 - 10:54 UTC

Investigating

Around 4:45 AM UTC we started experiencing lower iOS device availability in the US-West data center. Our team is actively investigating the root cause and working toward a resolution.
Posted Mar 19, 2026 - 09:51 UTC
This incident affected: Automated Real Device Testing (US-West) and Live Real Device Testing (US-West).