Sauce Labs Maintenance Window
We are experiencing intermittent issues with iOS Simulators and MacOS desktop browser tests in our US-West data center, caused by a third-party service disruption. Our engineering team is actively coordinating with the provider to restore full service.

2026-March-24 Resolved Service Incident

Incident Report for Sauce Labs

Postmortem

Dates:

Tuesday, March 24th 2026, 09:32 UTC – 15:13 UTC

What happened:

Network calls failed on iOS devices during Real Device Cloud sessions where network capture was enabled. Approximately 12-13% of iOS sessions were affected. Android was not impacted.

Why it happened:

A deployment introduced a DNS resolution change that was incompatible with the iOS platform, causing network capture to break.

How we fixed it:

Rolled back the deployment to restore service.

What we are doing to prevent it from happening again:

Adding synthetic tests to catch network capture regressions before production, and implementing monitoring alerts for faster detection after deployments.

Posted Apr 10, 2026 - 23:07 UTC

Resolved

Between 09:32 and 15:13 UTC, we identified a technical issue affecting iOS tests when running with network capture enabled. We've resolved the underlying cause and tests are working as expected. All services are fully operational.
Posted Mar 24, 2026 - 17:36 UTC