Sauce Labs Maintenance Window
We are experiencing intermittent issues with iOS Simulators and MacOS desktop browser tests in our US-West data center, caused by a third-party service disruption. Our engineering team is actively coordinating with the provider to restore full service.

2026-March-6 Resolved Service Incident

Incident Report for Sauce Labs

Postmortem

Dates:

Friday, March 6th 2026, 21:38 UTC - 23:11 UTC

What happened:

During the incident timeline, customers running virtual iOS simulator tests on ARM or macOS ARM desktop tests in the EU Data Center were unable to start new sessions for either live or automated.

Why it happened:

There was a sequencing issue on the release of the ARM side disk images in the EU.

How we fixed it:

The image reference for the ARM side disk was rolled back to the previous reference to restore service.

What we are doing to prevent it from happening again:

The tests that run to validate the image syncing have been completed in each region.

Posted Apr 10, 2026 - 22:55 UTC

Resolved

Between 21:38 UTC and 23:11 UTC, our virtual iOS and MacOS live and automated device tests were failing to start in the EU Data Center. We executed a deployment rollback, which restored services. All systems are now fully operational.
Posted Mar 06, 2026 - 21:38 UTC