Sauce Labs Maintenance Window
We are aware of an ongoing issue preventing logins to App Distribution when using Single Sign-On (SSO). We are actively investigating..

2026-January-29 Resolved Service Incident

Incident Report for Sauce Labs

Postmortem

Dates:

Thursday, January 29th 2026, 07:04 - 08:46 UTC.

What happened:

Between 07:04 UTC and 08:46 UTC on January 29, 2026, customers using our US-West-1 region experienced instability with Mac resources. Specifically:

  • Approximately 20% of iOS simulator jobs failed to start due to infrastructure errors.

  • 10% of Virtual MacOS/iOS jobs failed to upload assets to S3. As a result, logs, videos, and screenshots for these specific jobs were lost and remain unavailable for download.

Why it happened:

Scheduled maintenance on a primary network circuit coincided with high traffic volume, which led to congestion on the backup circuit.

How we fixed it:

Full connectivity was restored when traffic was routed back to the primary circuit following the completion of maintenance.

What we are doing to prevent it from happening again:

Review network redundancy strategies and consider upgrading backup circuit capacity to ensure it can support peak traffic loads.

Posted Feb 03, 2026 - 14:01 UTC

Resolved

Between 8:00 CET - 9:45 CET, We were seeing elevated error rates and intermittent issues with test assets not being retained for tests on iOS and Mac virtual devices in our US-West-1 data center. The issue has now been resolved but some customers might see missing test assets.
Posted Jan 29, 2026 - 11:11 UTC