Sauce Labs Maintenance Windows for Sauce Labs
Customers may experience intermittent errors during automated browser and virtual mobile device tests in our US-West-1 datacenter. We are closely monitoring and investigating the affected services.
2022-August-4 Service Incident
Incident Report for Sauce Labs
Resolved
App storage error rates are now back to normal levels along with Mac wait times being at expected levels. All services are fully operational.
Posted Aug 04, 2022 - 06:35 UTC
Monitoring
After taking remedial action we are seeing Mac wait times come down to normal levels and error rates on tests using app storage are coming down. We are monitoring.
Posted Aug 04, 2022 - 05:54 UTC
Update
We continue to see an elevated number of errors on our storage service. We additionally see intermittent high wait times on our Mac cloud. We continue to investigate.
Posted Aug 04, 2022 - 03:50 UTC
Investigating
We are seeing an elevated number of errors on our storage service affecting our Virtual and Real Device Cloud as well as any saucectl test in our US Data Center. We are investigating.
Posted Aug 04, 2022 - 02:55 UTC
This incident affected: Automated Virtual Mobile Device Testing (US-West), Automated Real Device Testing (US-West), Live Virtual Mobile Device Testing (US-West), Live Real Device Testing (US-West), and Native Framework Mobile App Testing (US-West).