Sauce Labs Partially Degraded Service
We are currently experiencing a slight reduction in available public and private iOS devices in the EU-Central Data Center. We expect to restore full availability for all iOS users in the EU-Central Data Center by tomorrow, Thursday, July 3, 2025, end of day

2024-August-15 Service Incident

Incident Report for Sauce Labs

Postmortem

Dates:

Thursday Aug 15th 2023, 17:24 - 19:05 UTC

What happened:

The SauceLabs Single Sign-on service suffered a failure causing customers using SSO to be unable to login to the UI. This incident did not impact automated testing.

Why it happened:

An invalid SauceLabs iDP was deployed.

How we fixed it:

We rolled back the configuration for the SauceLabs iDP, restoring service..

What we are doing to prevent it from happening again:

We’ve deployed stricter validation in our Single Sign-on service

Posted Aug 28, 2024 - 08:02 UTC

Resolved

This incident has been resolved.
Posted Aug 15, 2024 - 21:26 UTC

Investigating

We have received multiple reports of users experiencing issues accessing our dashboard via SSO. We are investigating.
Posted Aug 15, 2024 - 19:48 UTC
This incident affected: Sauce Labs Dashboard (US-West, EU-Central).