Sauce Labs Maintenance Windows for Sauce Labs
Sauce Labs will have a four hour previously scheduled maintenance window on Wednesday, July 10th, starting at 04:00 UTC and ending at 08:00 UTC. During this maintenance window, we will be making updates to our infrastructure and services in our US West data center. These maintenance actions may cause portions of the service (including running automated and manual tests) to be unavailable for up to four hours.
2024-May-28 Service Incident
Incident Report for Sauce Labs
Postmortem

Dates:

Tuesday May 28 2024, 13:42 - 14:41 UTC

What happened:

There was low availability of iOS17 devices in all of Sauce Labs DCs.

Why it happened:

A false positive check marked some devices as offline.

How we fixed it:

The check was fixed. 

What we are doing to prevent it from happening again:

We’ve implemented additional guard-rails and reduced the time to deploy.

Posted Jun 25, 2024 - 03:52 UTC

Resolved
After taking remedial action, the availability of iOS 17 real devices has returned to normal. This incident is resolved.
Posted May 28, 2024 - 14:41 UTC
Monitoring
After taking remedial action, the availability of iOS 17 real devices is returning to normal. We are currently monitoring.
Posted May 28, 2024 - 14:16 UTC
Investigating
We are experiencing reduced availability of iOS 17 Real devices in all our data centres. We are investigating.
Posted May 28, 2024 - 13:42 UTC
This incident affected: Automated Real Device Testing (US-West, EU-Central, US-East), Live Real Device Testing (US-West, EU-Central, US-East), and Native Framework Mobile App Testing (US-West, EU-Central).