Sauce Labs Maintenance Windows for Sauce Labs
Sauce Labs has consolidated onto one status page for all data centers.

The old status pages for US-West, US-East and EU-Central are still available to be able to view incident history. Anyone who was subscribed to notifications from one of the old status pages has been migrated onto this consolidated page. If you received an email saying that you had been unsubscribed from notifications, that was from one of the old pages and can be disregarded.

If you would like to select which components that you receive notifications for (e.g. if you are only interested in receiving notifications about incidents affecting Real Device Testing), you can access the subscription management page by clicking "Subscribe To Updates" above and enter the email address you are subscribed with. Additionally there is a "Manage Your Subscription" link on any email you will receive from the status page going forward.
2021-February-23 Service Incident
Incident Report for Sauce Labs
Postmortem

Dates:

Tuesday, February 24, 2:51am - 3:26am UTC

What happened:

Windows OS tests in the US-West and European regions experienced delays in their processing during a ~30-minute window.

Why it happened:

During the most recent OS update, a mismatch in configuration between two different components of our platform caused Windows tests to stall without being processed.

How we fixed it:

The affected service was rolled back to its previous version, restoring the original configuration.

What we are doing to prevent it from happening again:

We are changing our deployment procedures to avoid the issue in the future and accelerating our efforts to unify configuration information.

Posted Mar 02, 2021 - 19:16 UTC

Resolved
After taking remedial action, tests are back to their normal state. All services fully operational.
Posted Feb 24, 2021 - 02:47 UTC
Investigating
We are seeing PC jobs not start on our EU and US datacenter. We are taking remedial action.
Posted Feb 24, 2021 - 02:30 UTC
This incident affected: Live Virtual Mobile Device Testing (US-West, EU-Central), Automated Browser Testing (US-West, EU-Central), and Live Browser Testing (US-West, EU-Central).