Sauce Labs Maintenance Windows for Sauce Labs
We are currently performing maintenance that will affect the initiation of new Sauce Connect tunnel instances. The maintenance is expected to be completed by 2:00 PM PST. We appreciate your understanding and patience as we work to enhance our service.

2023-April-11 Service Incident

Incident Report for Sauce Labs

Postmortem

Dates:

Tuesday April 11th 2023, 09:09 - 10:05 UTC

What happened:

During the incident, any requests to start Appium sessions on Android devices requiring chromedriver version 112 or higher failed.

Why it happened:

This was caused due to an outdated version of chromedriver in our real device pool. The process that is responsible for keeping chromedriver up to date failed due to a bug. The bug also caused the alert mechanism to fail, causing a delay in our response.

How we fixed it:

We deployed a new version of the real device pool with the latest chromedriver versions.

What we are doing to prevent it from happening again:

We are addressing the bug in the chromedriver update process, which caused chromedriver to be out of date and delayed our response.

Posted May 03, 2023 - 14:36 UTC

Resolved

After taking remedial action, all Android Real Device sessions are starting as expected on both US-West-1 and EU-Central-1 data centers. This issue is now resolved, all services are fully operational.
Posted Apr 11, 2023 - 10:18 UTC

Investigating

Automated Android real device tests are intermittently failing to launch in our US-West-1 and EU-Central-1 data centers. We are actively investigating.
Posted Apr 11, 2023 - 09:21 UTC
This incident affected: Automated Real Device Testing (US-West, EU-Central).